python中的Numpy、MatPlotLib和SciPy模块的安装

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chao_8023/article/details/68929186

在使用Python进行数据处理时,经常使用到Numpy、MatPlotLib和SciPy这三个模块。在网上查了部分资料没有找到较为简单的安装方法,在安装过程中经常会遇到问题。下面详细说下我的安装过程。

1.安装Python。我安装的是3.6版本在安装配置中选择默认进行安装这里就不介绍了。

2.下载Numpy、MatPlotLib和SciPy,在第三方下载whl格式的文件。

Numpy:http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy

MatPlotLibhttp://www.lfd.uci.edu/~gohlke/pythonlibs/#matplotlib

SciPyhttp://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy


其中36代表python的版本  mkl库是安装scipy所需要的一个依赖库

3.把下载后的文件放到python安装目录的scripts下


4.顺序安装Numpy、MatPlotLib和SciPy

由于后两个库需要依赖numpy所以必须先安装numpy

在此目录下打开命令行窗口(快捷方式按住shift键点击鼠标右键 在此处打开命令窗口)

输入pip install xxx.whl进行安装

pip install "numpy-1.12.1+mkl-cp36-cp36m-win_amd64.whl"
pip install matplotlib-2.0.0-cp36-cp36m-win_amd64.whl
pip install scipy-0.19.0-cp36-cp36m-win_amd64.whl

看到 Successfully installed numpy-1.12.1+mkl即为安装成功


5.验证在python的命令行中输入

>>> from numpy import *
>>> from scipy import *
>>> from matplotlib import *

没有错误就安装成功了




展开阅读全文

没有更多推荐了,返回首页