pat 1134 顶点覆盖问题

题目描述:

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] ... v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line "Yes" if the set is a vertex cover, or "No" if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No

这道题就是判断是否当前输入的顶点集合是一个顶点覆盖,既边集中每个边至少有一个顶点在该覆盖中,一开始用了比较暴力的做法,即逐个边进行比较,发现超时了:

#include<iostream>
#include<stack>
#include<math.h>
#include<stdio.h>
typedef struct{
    int start;
    int end;
}node;
using namespace std;
int main(){
    node n[10001];
    int N,M;
    cin>>N>>M;
    for(int i=0;i<M;i++){
        cin>>n[i].start>>n[i].end;
    }
    int K;
    cin>>K;
    for(int i=0;i<K;i++){
        int query[10001];
        int test[10001]={0};
        int Nv;
        bool flag=true;
        cin>>Nv;
        for(int j=0;j<Nv;j++)
            cin>>query[j];
        for(int j=0;j<Nv;j++){
            for(int k=0;k<M;k++){
                if(query[j]!=n[k].start&&query[j]!=n[k].end){
                    continue;
                }
                else{
                    test[k]=1;
                }
            }
        }
        for(int j=0;j<M;j++){
            if(test[j]==0){
                flag=false;
                break;
            }
        }
        if(flag) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}
很显然这种暴力的做法复杂度较高,如果是最坏的情况下会比较很多次,因此后来想了很久,终于想出了将每个边进行标号处理,然后存在每个顶点信息中,这样就简化了许多。

#include<iostream>
#include<stack>
#include<math.h>
#include<stdio.h>
typedef struct{
    int length=0;
    int ele[10001];
}node;
node n[10001];
using namespace std;
int main(){
    int N,M;
    cin>>N>>M;
    for(int i=0;i<M;i++){
        int start,end;
        cin>>start>>end;
        n[start].ele[n[start].length++]=i;
        n[end].ele[n[end].length++]=i;
    }
    int K;
    cin>>K;
    for(int i=0;i<K;i++){
        int Nv;
        cin>>Nv;
        int test[10001]={0};
        for(int j=0;j<Nv;j++){
            int q;
            cin>>q;
            for(int k=0;k<n[q].length;k++)
                test[n[q].ele[k]]++;
        }
        bool flag=true;
        for(int j=0;j<M;j++){
            if(test[j]==0){
                flag=false;
                break;
            }
        }
        if(flag) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值