ACdream 之ACfun 题解

A - ACfun

Time Limit:  2000/1000MS (Java/Others)  Memory Limit:  128000/64000KB (Java/Others)
Problem Description
题目链接 点击打开链接
As a former ACMer, "AC" is a special abbreviated word which can bring much pleasure to me. Sometimes it means everything.
This problem is about "AC".
One day, I write a long string S on the paper which contains "A" and "C". Now I want to find a lexicographic minimum string T satisfied that T is distinct with all substring of S.
Input
The first line of input file contains an integer T indicating the number of case.
In each test case:
Input a string S consist of "A" and "C". The length of S is not large than 100.
Output
For each test case:
You should output the string T meet the condition.
Sample Input
1
ACAC
Sample Output
AA
大致意思就是,找出最长连续的A的数目num然后再输出num+1个A,题目我是没看出来有说这个东西。只是看队友A了问了才知道的,希望ACdream以后出题能考虑到这点吧哭
代码:
/*
* this code is made by chaoyueziji
* Problem: 1125
* Verdict: Accepted
* Submission Date: 2014-07-11 22:56:21
* Time: 0MS
* Memory: 1676KB
*/
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
 char s[1001];
 int i,j,k,l,t;
 int sum,max;
 cin>>t;
 getchar();
 while(t--)
 {
     sum=max=0;
   gets(s);
   for(i=0;i<strlen(s);i++)
   {
       if(s[i]=='A')
       { sum=1;
            
         for(j=i+1;j<strlen(s);j++)
         {
           if(s[i]==s[j])
               sum++;
           if(sum>max)
           max=sum;
           if(s[i]!=s[j])
           {
               sum=1;
               break;
           }
         }
       }
   }
   for(i=0;i<=max;i++)
       printf("A");
   printf("\n");
 }
 return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值