PAT A1139 First Contact (30分)

PAT甲级:1139 First Contact (30分)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0
  • 题意:在旧年代,男女生间示爱都比较含蓄,所以如果a对b有好感,a不会直接告诉b,而是通过找a自己的好朋友c让b的好朋友d来帮忙转达消息给b。但有个问题是这种秘密一般不想让异性朋友知道,所以a找的朋友一定是自己的同性朋友c,同样c也要去找b的同性朋友d来转达消息。题目要求找到满足条件的能帮助a传达消息的一对朋友。
  • 分析:题目整体思路是比较直观的,就是记录每个人的所有朋友,遍历a的朋友同时遍历b的朋友,如果两个人彼此是朋友,那这一对就是符合条件的。另外还有其他注意点:题目读入的数据是整型,通过正负号表示性别,那么如果输入的是 -0000,则会被视作是0,因此需要用字符串接收编号。再一点,因为c、d分别和a、b同性别,所以输入数据的时候干脆就只存储与自己同性的朋友,但是c和d是可以不同性的,因此朋友关系仍然需要全部记录。之后记录答案时,朋友成对存在,因此使用pair<int, int>存储。之后根据要求编写排序函数。
#include <bits/stdc++.h>
using namespace std;
bool cmp(pair<int, int> a, pair<int, int> b) {
    return a.first != b.first ? a.first < b.first : a.second < b.second;
}
int main() {
    int n, m, k;
    unordered_map<int, bool> isfriend;
    vector<int> f[10000];
    string a, b;
    scanf("%d%d", &n, &m);
    for (int i = 0; i < m; i++) {
        cin >> a >> b;
        int ia = abs(stoi(a)), ib = abs(stoi(b));
        if (a.length() == b.length()) {
            f[ia].push_back(ib);
            f[ib].push_back(ia);
        }
        isfriend[ia * 10000 + ib] = isfriend[ib * 10000 + ia] = true;
    }
    scanf("%d", &k);
    while (k--) {
        cin >> a >> b;
        int ia = abs(stoi(a)), ib = abs(stoi(b));
        vector<pair<int, int> > ans;
        for (auto ta : f[ia]) {
            if (ta == ib) continue;
            for (auto tb : f[ib]) {
                if (tb != ia && isfriend[ta * 10000 + tb]) {
                    ans.push_back({ta, tb});
                }
            }
        }
        printf("%d\n", ans.size());
        sort(ans.begin(), ans.end(), cmp);
        for (auto it : ans) printf("%04d %04d\n", it.first, it.second);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值