PAT A1106 Lowest Price in Supply Chain (25分) (DFS+剪枝)

PAT甲级:A1106 Lowest Price in Supply Chain (25分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2
  • 题意:转述题意,一棵树中根结点是 供应商、叶子结点是 零售商、中间结点均为 经销商,零售商将供应商提供的商品销售出去需要经过一个或多个经销商,每经一个经销商价格都会增加 r%,问客户从零售商处购买商品可以得到的最低价格是多少,共有多少个零售商可以提供这样的最低价。
  • 分析:这是树的深度优先搜索问题,在 dfs 函数中需要维护 当前结点编号当前价格 两个参数,当到达叶子结点的时候判断当前价格是否小于最小价格即可。这里可以适当剪枝,即当price小于或等于最低价格时才继续向下搜索,但实际上提交代码后发现耗时没什么区别。
#include <bits/stdc++.h>
using namespace std;
const int N = 100010;
vector<int> e[N], ans;
int n, k, cntMin = 0;
double r, p, minPrice = 0x3f3f3f3f;
void dfs(int u, double price) {
    if (e[u].size() == 0) {
        if (price < minPrice) {
            minPrice = price;
            cntMin = 1;
        } else if (price == minPrice) {
            cntMin++;
        }
        return;
    }
    for (auto it : e[u]) {
        double tempP = price * (1 + r / 100);
        if (tempP <= minPrice) dfs(it, tempP);
    }
}
int main() {
    scanf("%d%lf%lf", &n, &p, &r);
    for (int i = 0; i < n; i++) {
        scanf("%d", &k);
        int temp;
        while (k--) {
            scanf("%d", &temp);
            e[i].push_back(temp);
        }
    }
    dfs(0, p);
    printf("%.4f %d", minPrice, cntMin);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值