vue 项目,下载别人的项目和npm run dev报错解决方法

npm install

npm run dev

通常在npm install 有时候会出错

$ cnpm install
× Install fail! Error: [boostrap@^4.2.1]Can’t find package boostrap@^4.2.1
Error: [boostrap@^4.2.1] Can’t find package boostrap@^4.2.1
at resolve (C:\Users\Mi\AppData\Roaming\npm\node_modules\cnpm\node_modules\npminstall\lib\download\npm.js:78:11)
at resolve.next ()
at onFulfilled (C:\Users\Mi\AppData\Roaming\npm\node_modules\cnpm\node_modules\co\index.js:65:19)
at process._tickCallback (internal/process/next_tick.js:68:7)
npminstall version: 3.20.2
npminstall args: C:\Program Files\nodejs\node.exe C:\Users\Mi\AppData\Roaming\npm\node_modules\cnpm\node_modules\npminstall\bin\install.js --fix-bug-versions --china --userconfig=C:\Users\Mi.cnpmrc --disturl=https://npm.taobao.org/mirrors/node --registry=https://registry.npm.taobao.org

注意:‘’Can’t find package boostrap@^4.2.1
这是因为自己项目的朋友一开始使用了,但是后来觉得还是用其他框架
忘记删除
所以在package.json里
找到 boostrap@^4.2.1 把它删掉就可以了

 

vue 项目,npm run dev报错解决方法
```
$ cnpm run dev

> project@1.0.0 dev D:\codeword\vue\project
> webpack-dev-server --inline --progress --config build/webpack.dev.conf.js

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! project@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the project@1.0.0 dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Mi\AppData\Roaming\npm-cache\_logs\2019-02-27T12_54_21_588Z-debug.log

```
网上查

原因:这是新版webpack存在的BUG,卸载现有的新版本webpack,装老版本就好。

(1)、cnpm uninstall webpack-dev-server

(2)、cnpm install webpack-dev-server@2.9.1

(3)、cnpm run dev

 

 

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客
应支付0元
点击重新获取
扫码支付

支付成功即可阅读