题目描述
建立一个顺序表L,然后以第一个为分界,将所有小于等于它的元素移到该元素的前面,将所有大于它的元素移到该元素的后面。
输入
顺序表长度n;
顺序表中的数据元素。
输出
移动后的数据元素。
样例输入
10
32 5 22 43 23 56 54 57 11 25
样例输出
25 11 23 22 5 32 43 56 54 57
#include<stdio.h>
#include<malloc.h>
#define MaxSize 1000
typedef struct node
{
int data[MaxSize];
int length=0;
}List;
void init(List*&L)
{
L=(List*)malloc(sizeof(List));
L->length=0;
}
void Insert(List*&L,int num)
{
L->data[L->length++]=num;
}
int main()
{
List *L;
init(L);
int n,num;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&num);
Insert(L,num);
}
//从后往前,找到<=首元素的数据输出
//从前往后,找到>首元素的数据输出
int i=1,j=n-1;
while(j>=1)
{
if(L->data[j]<=L->data[0])
{
printf("%d ",L->data[j]);
}
j--;
}
printf("%d ",L->data[0]);
while(i<n)
{
if(L->data[i]>L->data[0])
{
printf("%d ",L->data[i]);
}
i++;
}
}