HDU 5469(2015 ICPC上海网络赛)---Antonidas(树上分治)

题目链接
http://acm.hdu.edu.cn/showproblem.php?pid=5469

Problem Description
Given a tree with N vertices and N−1 edges. Each vertex has a single letter Ci. Given a string S, you are to choose two vertices A and B, and make sure the letters catenated on the shortest path from A to B is exactly S. Now, would you mind telling me whether the path exists?

Input
The first line is an integer T, the number of test cases.
For each case, the first line is an integer N. Following N−1 lines contains two integers a and b, meaning there is an edge connect vertex a and vertex b.
Next line contains a string C, the length of C is exactly N. String C represents the letter on each vertex.
Next line contains a string S.
1≤T≤200, 1≤N≤104, 1≤a,b≤N, a≠b, |C|=N, 1≤|S|≤104. String C and S both only contain lower case letters.

Output
First, please output “Case #k: “, k is the number of test case. See sample output for more detail.
If the path exists, please output “Find”. Otherwise, please output “Impossible”.

Sample Input
2

7
1 2
2 3
2 4
1 5
5 6
6 7
abcdefg
dbaefg

5
1 2
2 3
2 4
4 5
abcxy
yxbac

Sample Output
Case #1: Find
Case #2: Impossible

Source
2015 ACM/ICPC Asia Regional Shanghai Online

Recommend
hujie | We have carefully selected several similar problems for you: 5960 5959 5958 5957 5956

题意:一棵树有n个节点、n-1条边,每个节点上有一个小写英文字母,现有一个只含有英文小写字母的字符串s,问这棵树上是否存在一条路径,串成的字符串和字符串s相同,存在输出“Find” 否则输出“Impossible”;

思路:树上分治,先找到字母为s[0]的节点,然后以它为起点,向下孩子节点或者向上父亲节点搜索,注意剪枝,当向下孩子节点搜索时深度(到叶子节点的最大长度)小于剩余字符串长度时,不必往下搜索。另外,在分治搜索之前,要处理处每个节点的父亲节点和自己的深度;

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
typedef long long LL;
const int maxn=1e4+5;
char C[maxn],S[maxn];
int par[maxn],h[maxn];
bool vis[maxn];
vector<int>q[maxn];
int N,len;

void dfs1(int t,int p)
{
    int tmp=0;
    for(int i=0;i<q[t].size();i++)
    {
        if(q[t][i]!=p){
            par[q[t][i]]=t;
            dfs1(q[t][i],t);
            tmp=max(tmp,h[q[t][i]]);
        }
    }
    h[t]=tmp+1;
}

bool dfs2(int t,int l)
{
    if(l==len) return true;
    for(int i=0;i<q[t].size();i++)
    {
        if(q[t][i]!=par[t]&&len-l<=h[q[t][i]]&&!vis[q[t][i]]&&C[q[t][i]]==S[l]){
            vis[t]=1;
            if(dfs2(q[t][i],l+1)) return true;
            vis[t]=0;
        }
    }
    if(!vis[par[t]]&&C[par[t]]==S[l]){
        vis[t]=1;
        if(dfs2(par[t],l+1)) return true;
        vis[t]=0;
    }
    return false;
}

int main()
{
    int T,Case=1;
    cin>>T;
    while(T--)
    {
        scanf("%d",&N);
        for(int i=0;i<=N;i++)
            q[i].clear();
        for(int i=1;i<N;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            q[u].push_back(v);
            q[v].push_back(u);
        }
        par[1]=0;
        dfs1(1,0);
        scanf("%s%s",C+1,S);
        int flag=0;
        len=strlen(S);
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=N;i++)
        {
            if(C[i]==S[0])
            if(dfs2(i,1)) { flag=1; break; }
        }
        printf("Case #%d: ",Case++);
        if(flag)  puts("Find");
        else      puts("Impossible");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值