安装Docker CE、安装最新版Docker

基于CentOS安装Docker CE、安装最新版Docker

一、Docker版本分支问题
2017年3月 docker在原来的基础上分为两个分支版本:
Docker CE 和Docker EE。Docker CE即社区版,免费,Docker EE即企业版,强调安全,付费使用。因此本文基于CentOS7 安装Docker CE
二、Docker CE安装
(1)系统版本要求
在安装Docker前需要确保操作系统内核版本为 3.10以上,因此需要CentOS7 ,CentOS7内核版本为3.10。

(2)检查是否安装过旧的版本
如果系统安装旧版本Docker需要先卸载,命令如下:

$ sudo yum remove docker \
                  docker-common \
                  docker-selinux \
                  docker-engine

(3)安装Docker CE
1、本文基于yum方式安装,需要安装以下的依赖包:yum-utils 、device-mapper-persistent-dat

  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值