*寒假水17—— Switch Game

 

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

InputEach test case contains only a number n ( 0< n<= 10^5) in a line. 
OutputOutput the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).Sample Input

1
5

Sample Output

1
0


        
  

Consider the second test case:

The initial condition	   : 0 0 0 0 0 …
After the first operation  : 1 1 1 1 1 …
After the second operation : 1 0 1 0 1 …
After the third operation  : 1 0 0 0 1 …
After the fourth operation : 1 0 0 1 1 …
After the fifth operation  : 1 0 0 1 0 …

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

Hint

hint
      

 

#include<stdio.h>
int main()
{
	int i,n,k;
	while(scanf("%d",&n)!=EOF)
	{
		k=0;
		for(i=1;i<=n;i++)
		{
			if(n%i==0)
			{
				k++;
			}
		}
		if(k%2==0)
		{
			printf("0\n");
		}
		else
		{
			printf("1\n");
		}
	}
	return 0;
}

题解:这道题是酱紫的~求输入数据n的约数个数,若为奇数个,输出1;偶数输出0.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值