*寒假水91——辗转相除法求最大公约数 【辗转相除法】

 

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 
 

InputInput will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer. 
OutputFor each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer. 
Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

 

#include<iostream>

using namespace std;

int bear(int a,int b)
{
    int temp;
    if(a<b)
    {
        temp=a;
        a=b;
        b=temp;
    }
    while(b!=0)
    {
        temp=a%b;
        a=b;
        b=temp;
    }
    return a; 
}

int lcm(int a,int b)
{
    int c;
    c=a/bear(a,b)*b;
    return c;
}

int main()
{
    int i,n,m,x,y,ans;

    cin>>n;
    while(n--)
    {
        cin>>m>>ans;
        for(i=0;i<m-1;i++)
        {
            cin>>y;
            ans=lcm(y,ans);
        }
        cout<<ans<<endl;
    }
    return 0;
} 

题解:王岐叔叔讲过的题呀。开心。

就是大的除小的,小的作为新的大的,取模做为新的小的,最后得到的数就是最大公约数。

最小公倍数就是所有数相乘,再除以最大公约数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值