*寒假水99——素数表 【筛法求素数】

 

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively. 
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

InputThe input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.OutputFor each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

 

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#define Max 1040000  

using namespace std;  

int notprime[Max];  
int prime[Max],cntprime;  
int power[5]={1,10,100,1000,10000}; 
int k[25],cnt,pos,l;  
char c[105];

void findprime()         
{  
    notprime[2]=0;  
    for (int i=2;i<Max;i++)  
    {  
        if (!notprime[i])  
        {  
            cntprime++;  
            prime[cntprime]=i;  
            for (int j=2;j*i<Max;j++)  
            {  
                notprime[i*j]=1;  
            }  
        }  
    }  
    return ;  
}  

int main()  
{  
    findprime();    
    scanf("%s%d",c,&l);  
    while (l)  
    {  
        cnt=0;pos=0;  
        k[0]=0;  
        for (int i=strlen(c)-1;i>=0;i--)
        {  
            k[pos]+=(c[i]-'0')*power[cnt];  
            cnt++;  
            if (cnt==5)  
            {  
                pos++;  
                k[pos]=0;  
                cnt=0;  
            }  
        }  
        if(!cnt)  
            pos--;   
        int flag=1;  
        long long mod;    
        for (int i=1;i<=cntprime && prime[i]<l && flag;i++)  
        {  
            mod=0;  
            for (int j=pos;j>=0;j--)  
            {  
                mod=(mod*100000+k[j])%prime[i];  
            }   
            if (!mod)   
            {  
                flag=0;  
                printf("BAD %d\n",prime[i]);  
            }  
        }  
        if (flag) printf("GOOD\n");  
        scanf("%s%d",c,&l);  
    }  
    return 0;  
}  

题解:数据范围很大,所以先筛出一张素数表。

K的值较大,达到了1e+100。明显超出了long long的范围。这里我们可以采用万进制。即将K(例如K=abcdefghi转化成K=abcd*100000+efghi)余数就是((abcd%L)*100000+efghi)%L,注意,这个余数会超出int,建议使用long long。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值