*寒假水101——枚举答案能不能做?

 

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39. 

InputThe input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero. 
OutputFor each integer in the input, output its digital root on a separate line of the output. 
Sample Input

24
39
0

Sample Output

6
3

 

#include<iostream>
#include<stdio.h>  
#include<string.h>

using namespace std;
  
int main()  {  
    int i,n,t,ans;  
    char a[10000];  
    while(gets(a)){  
        if(strcmp(a,"0")==0){
            break;	
        }  
        n=strlen(a);  
        ans=0;  
        for(i=0;i<=n-1;i++){  
            ans+=a[i]-'0';  
        }  
        while(ans>=10){  
            t=ans;  
            ans=0;  
            while(t){  
                ans+=t%10;  
                t=t/10;  
            }  
        }  
        cout<<ans<<endl;  
    }  
    return 0;  
}  

题解:数字根的题做过,不难。。。。。。而这道题明确的说,枚举WA。吓得宝宝哇的一声哭出来了。

没错,怎么定义这个数都有问题。哼!哼!哼!

把它定义成字符串,我就不信它装不下。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值