hdu 1099 lottery

Lottery

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1086    Accepted Submission(s): 537


Problem Description
Eddy's company publishes a kind of lottery.This set of lottery which are numbered 1 to n, and a set of one of each is required for a prize .With one number per lottery, how many lottery on average are required to make a complete set of n coupons?
 

Input
Input consists of a sequence of lines each containing a single positive integer n, 1<=n<=22, giving the size of the set of coupons.
 

Output
For each input line, output the average number of lottery required to collect the complete set of n coupons. If the answer is an integer number, output the number. If the answer is not integer, then output the integer part of the answer followed by a space and then by the proper fraction in the format shown below. The fractional part should be irreducible. There should be no trailing spaces in any line of ouput.
 

Sample Input
  
  
2 5 17
 

Sample Output
  
  
3 5 11 -- 12 340463 58 ------ 720720
 

Author
eddy
 

Recommend
JGShining
 


拿到第一张卡片的概率是 n/n ,期望次数是 1,拿到第二张的概率是 (n-1)/n, 期望次数是 n/(n-1) ...

把这些次数加起来 n/n + n/(n-1) + ... + n/1


don 分母 doneminator

num 分子 numerator

ws 空格  white space

ln  分数线 line


http://acm.hdu.edu.cn/forum/read.php?tid=16311&keyword=1099


#include <cstdlib>
#include <cstdio>
#include <cassert>
#include <cstring>
#include <algorithm>

long long GCD (long long a, long long b) {
    if (b == 0) {
        return a;
    }
    return GCD (b, a % b);
}

int main () { 
    long long n;
    while (scanf ("%lld", &n) == 1) {
        long long don = 1, num = 0;
        for (long long i=1; i<=n; ++i) {
            num = num * i + n * don;
            don = don * i;
            long long gcd = GCD (don, num);
            don = don / gcd;
            num = num / gcd;
        }
        if (num % don == 0) {
            printf ("%lld\n", num / don);
        } else {
            static char strInt[1024], strNum[1024], strDon[1024];
            static char strWS[1024], strLn[1024];
            static char ws[] = "                              ";
            static char ln[] = "------------------------------";

            sprintf (strInt, "%lld", num / don);
            sprintf (strNum, "%lld", num % don);
            sprintf (strDon, "%lld", don);

            memset (strWS, 0, sizeof (strWS));
            strncpy (strWS, ws, strlen (strInt));

            memset (strLn, 0, sizeof (strLn));
            strncpy (strLn, ln, std::max (strlen (strNum), strlen (strDon)));

            printf ("%s %s\n%s %s\n%s %s\n", strWS, strNum, strInt, strLn, strWS, strDon);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值