复试训练——贪心算法

题目1433:FatMouse

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:3774

解决:1675

题目描述:

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

输入:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入:

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

样例输出:

13.333
31.500

代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
struct goods{
     double j;
	 double f;
	 double s;
	 bool operator <(const goods &A) const{
	      return s>A.s;
	 }
}buf[1000];
int main(){
     double m;
	 int n;
	 while(scanf("%lf%d",&m,&n)!=EOF){
	    if(m==-1&&n==-1) break;
		int i;
		for(i=0;i<n;i++){
           scanf("%lf%lf",&buf[i].j,&buf[i].f);
		   buf[i].s=buf[i].j/buf[i].f;
		}
		sort(buf,buf+n);
		int idx=0;
		double ans=0;
		while(m>0&&idx<n){
			if(m>buf[idx].f){
			   ans+=buf[idx].j;
			   m-=buf[idx].f;
			}
			else{
			     ans+=buf[idx].j*m/buf[idx].f;
				 m=0;
			}
			idx++;
		}
		printf("%.3lf\n",ans);
	 }
	 return 0;
}

题目1434:今年暑假不AC

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:3511

解决:1855

题目描述:

“今年暑假不AC?”“是的。”“那你干什么呢?”“看世界杯呀,笨蛋!”“@#$%^&*%...”确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)

输入:

输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。

输出:

对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。

样例输入:

12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0

样例输出:

5

代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
struct program{
	int startTime;
	int endTime;
	bool operator <(const program &A) const{
	return endTime<A.endTime;
	}
}buf[100];
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		if(n==0)break;
		int i;
		for(i=0;i<n;i++){
			scanf("%d%d",&buf[i].startTime,&buf[i].endTime);
		}
		sort(buf,buf+n);
		int currentTime=0,ans=0;
		for(i=0;i<n;i++){
			if(currentTime<=buf[i].startTime){
				ans++;
				currentTime=buf[i].endTime;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

转载于:https://my.oschina.net/u/1996306/blog/830953

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值