Funny Game

Description

  Two players, Singa and Suny, play, starting with two natural numbers. Singa, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Suny, the second player, does the same with the two resulting numbers, then Singa, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

         25 7
 
         11 7
 
          4 7
 
          4 3
 
          1 3
 
          1 0
 
an Singa wins.
Input

 The input consists of a number of lines. Each line contains two positive integers (<2^31) giving the starting two numbers of the game. Singa always starts first. The input ends with two zeros.

Output

 For each line of input, output one line saying either Singa wins or Suny wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input
 Copy sample input to clipboard
28 15
15 24
0 0
Sample Output
Singa wins  
Suny wins
博弈题目
// Problem#: 8587
// Submission#: 2193605
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
using namespace std;
bool game(int m,int n)
{
    if(m<n)
    {
        int temp=n;
        n=m;
        m=temp;
    }
    if(m/n<2)
    {
        if(m%n==0)
            return 1;
        else return !game(m-n,n);//一倍以下的,不能控制比赛
    }
    return 1;//如果是在两倍以上,他可以任意选择,控制比赛
}
int main()
 {
   int m,n;
  while(cin>>m>>n&&m&&n)
  {
     if(game(m,n))
      cout<<"Singa wins"<<endl;
     else cout<<"Suny wins"<<endl;
   }
    return 0;
}                                 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值