-source 1.5 中不支持 diamond 运算 请使用 -source 7 或更高版本以启用

版权声明:本文为博主原创文章,欢迎转载。 https://blog.csdn.net/chengyuqiang/article/details/79975797

1、遇到问题

Maven打包

C:\Users\chengyq\eclipse-workspace\webservice>mvn package

需要如下错误

[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /D:/Users/chengyq/eclipse-workspace/webservice/src/main/java/com/cntaiping/tpa/util/Dom4jUtil.java:[251,60] -source 1.5 中不支持 diamond 运算
符
  (请使用 -source 7 或更高版本以启用 diamond 运算符)
[ERROR] /D:/Users/chengyq/eclipse-workspace/webservice/src/main/java/com/cntaiping/tpa/util/FileUtil.java:[170,51] -source 1.5 中不支持 diamond 运算符

解决办法:
可以在pom.xml中加入下面的东西即可

<properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
</properties>

重启打包即可。

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页