题目1001:A+B for Matrices

题目:http://ac.jobdu.com/problem.php?pid=1001
题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
刚开始的时候,题目没看懂!其实题目很简单!就是把两个矩阵相加,计算出结果矩阵中行全为0的行数加上列全为0的列数! 
代码如下:
#include <iostream>
#include <cstdio>
using namespace std;


#define N 20
int matrix[N][N];

int answer(int n,int m,int times)
{
    int i,j,flag;
    int ans = 0;
    for(i = 0;i < n;i++)
    {
          flag = 1;
          for(j = 0; j < m;j++)
          {
                if(times == 1)
                {
                         
                         if(matrix[i][j] != 0)
                                         flag = 0;
                }
                else
                {
                         if(matrix[j][i] != 0)
                                         flag = 0;
                }
          }
          if(flag)
                  ans++;
    }
    return ans;
   
}
                    
int main()
{
    int n,m,tmp,i,j,ans;
    while(scanf("%d",&n) == 1)
    {
                    if(!n)break;
                    scanf("%d",&m);
                    for(i = 0;i < n;i++)
                          for(j = 0;j < m;j++)
                                scanf("%d",&matrix[i][j]);
                    for(i = 0; i < n;i++)
                          for(j = 0;j < m;j++)
                          {
                                scanf("%d",&tmp);
                                matrix[i][j] += tmp;
                          }
                    ans = 0;
                    ans += answer(n,m,1);
                    ans += answer(m,n,2);
                    printf("%d\n",ans);
                    
                    
    }
    return 0;
}


 
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值