uva10161 Ant on a Chessboard

Description


 

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

 

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

 

 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

 

 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

 

 

Sample Input

8

20

25

0

 

 

Sample Output

2 3

5 4

1 5


注:
本题目意思很好理解,就是以螺旋的形式数字从小到大,一圈一圈旋转!输入数字N,输出N在螺旋圈中的坐标!本题的关键就是找出规律,首先可以确定在一个正方形中找规律,经观察发现,正方形中对角线上的元素可以表示为a*(a -1)+1,其中a为正方形的边长!从而再确定所找的数位于边长为奇数还是边长为偶数的正方形的最外层边界上!再更行判断就可以得出结果了!!
以下是AC代码:
#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
    int n , q ,ans;
    while(scanf("%d",&n) == 1)
    {
                if(!n)break;
                q = (int) ceil(sqrt(n));//找出正方形的边长 
                ans = q * (q - 1) + 1;//对角线上的最外层的元素 
                if(q & 1)//注意判断大小 
                {
                     if(n >= ans)
                          printf("%d %d\n",q -(n - ans),q);
                     else
                          printf("%d %d\n",q,q - (ans - n));
                }
                else
                {
                    if(n >= ans)
                        printf("%d %d\n",q,q -(n - ans));
                    else
                        printf("%d %d\n",q -(ans - n),q);
                        
                }
    }
    return 0;
}
                                   
    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值