Fibonacci Again
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 208 Accepted Submission(s) : 110
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
#include<iostream>
using namespace std;
void doProcess(int n)
{
if (n%4==2)
{
cout<<"yes"<<endl;
}
else
cout<<"no"<<endl;
}
int main()
{
long n;
while (cin>>n)
{
doProcess(n);
}
return 0;
}