The Heaviest Non-decreasing Subsequence Problem(LIS+思维)

题目链接:

Let SS be a sequence of integers s_{1}s1s_{2}s2......s_{n}sn Each integer is is associated with a weight by the following rules:

(1) If is is negative, then its weight is 00.

(2) If is is greater than or equal to 1000010000, then its weight is 55. Furthermore, the real integer value of s_{i}si is s_{i}-10000si10000 . For example, if s_{i}si is 1010110101, then is is reset to 101101 and its weight is 55.

(3) Otherwise, its weight is 11.

A non-decreasing subsequence of SS is a subsequence s_{i1}si1s_{i2}si2......s_{ik}sik, with i_{1}<i_{2}\ ...\ <i_{k}i1<i2 ... <ik, such that, for all 1 \leq j<k1j<k, we have s_{ij}<s_{ij+1}sij<sij+1.

A heaviest non-decreasing subsequence of SS is a non-decreasing subsequence with the maximum sum of weights.

Write a program that reads a sequence of integers, and outputs the weight of its

heaviest non-decreasing subsequence. For example, given the following sequence:

8080 7575 7373 9393 7373 7373 1010110101 9797 -11 -11 114114 -11 1011310113 118118

The heaviest non-decreasing subsequence of the sequence is <73, 73, 73, 101, 113, 118><73,73,73,101,113,118> with the total weight being 1+1+1+5+5+1 = 141+1+1+5+5+1=14. Therefore, your program should output 1414 in this example.

We guarantee that the length of the sequence does not exceed 2*10^{5}2105

Input Format

A list of integers separated by blanks:s_{1}s1s_{2}s2,......,s_{n}sn

Output Format

A positive integer that is the weight of the heaviest non-decreasing subsequence.

样例输入
80 75 73 93 73 73 10101 97 -1 -1 114 -1 10113 118
样例输出
14


题意:给出一个序列,并赋予每个数权值,负数权值为0,0~9999权值为1,10000以上权值为5。求非减子序列的最大权值和,但是在判定是否为非减子序列时,最10000以上的值要减去10000,但其权值保持不变。


题解:负数权值为0,不用管。剩下的分为两个等级1和5,如果只有1或5,即每个数权值相同,那么只需求最长非减子序列即可。可是现在有两个值,怎么办呢?将5变成5个1!即把权值为5的数原地复制成5个相同的数,由于是非减序列,这样做并不会影响原来的序列,再求一个最长非减子序列即可


#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 1e6 + 10;
int a[maxn];
int dp[maxn];

void Add(int k, int& i)     //在数组中加入这个值
{
    if(k >= 10000){
        k -= 10000;
        for(int j = 0; j < 5; j++) a[i++] = k;
    }
    else if(k > 0 && k < 10000) a[i++] = k;
}

int main()
{
    int k, i = 0;
    scanf("%d", &k);
    Add(k, i);
    while(getchar() == ' '){
        scanf("%d", &k);
        Add(k, i);
    }
    int n = i;

    fill(dp, dp + n, INF);
    for(int i = 0; i < n; i++){
        *upper_bound(dp, dp + n, a[i]) = a[i];
    }
    cout<<lower_bound(dp, dp + n, INF) - dp<<endl;

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值