时间限制:3000 ms | 内存限制:65535 KB
难度:3
描述
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);
1.按照编号从小到大排序
2.对于编号相等的长方形,按照长方形的长排序;
3.如果编号和长都相同,按照长方形的宽排序;
4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
输入
第一行有一个整数 n(0-10000),表示接下来有n组测试数据;
每一组第一行有一个整数 m(0-1000),表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,
第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
- 1
- 8
- 1 1 1
- 1 1 1
- 1 1 2
- 1 2 1
- 1 2 2
- 2 1 1
- 2 1 2
- 2 2 1
样例输出
- 1 1 1
- 1 2 1
- 1 2 2
- 2 1 1
- 2 2 1
**
题解分析
**
对于这道难度为3的题目,其实就是考察怎么进行自定义的排序,
在C++语言中,STL类库提供了sort排序,在排我们自定义的数据结构的时候,需要进行“<” 运算符的重载,
C++中的sort函数的头文件是 ”algorithm“;
sort函数的三个参数
第一个;开始值的地址
第二个;结束值的地址
第三个;排序的函数,若没有则默认为升序排列;记住函数return中大于为降序,小于为升序。
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
struct Rect{
int num;
int length;
int width;
};
bool cmp(Rect a,Rect b){
if(a.num!=b.num) return a.num<b.num;
if(a.length!=b.length) return a.length<b.length;
return a.width<b.width;
}
int main ()
{
int n;
cin>>n;
while(n--){
int m;
cin>>m;
vector<Rect> vec;
for(int i=0;i<m;i++){
int a,b,c;
cin>>a>>b>>c;
Rect rect;
rect.num=a;
rect.length=b>c?b:c;
rect.width=b<c?b:c;
vec.push_back(rect);
}
sort(vec.begin(),vec.end(),cmp);
vector<Rect>::iterator t=vec.begin(),it;
it=t;
cout<<(*t).num<<" "<<(*t).length<<" "<<(*t).width<<endl;
for(it++;it!=vec.end();it++,t++){
if((*it).num==(*t).num && (*it).length==(*t).length && (*it).width==(*t).width) continue;
cout<<(*it).num<<" "<<(*it).length<<" "<<(*it).width<<endl;
}
}
return 0;
}
在本题中运用了STL类库中的vector容器,用不定长数组存放数据,防止溢出
更多内容可关注我的个人博客MyBlog