HDU - 2196 Computer (树的直径)

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33989    Accepted Submission(s): 5236


 

Problem Description

A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.



Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

 

 

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

 

 

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

 

 

Sample Input

 

5 1 1 2 1 3 1 1 1

 

 

Sample Output

 

3 2 3 4 4

 

 

 

       大意就是一棵树,问某一个点能够走的不重复点的最长的路径是多少;

       其实所有的树都能化成一下图形,而最中间的那个便叫做树的直径; 

       按照树的直径的特性。。你可以发现,任选一点开始bfs,他能到达的最远的点,便是两个直径点的其中一个,在从这个点开始遍历,最远的点便是另一个直径点了,这样我们求得之后,任意一点得最长路径,便是他与这两个直径点得距离得最大值;

        得解。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 40010;
const int inf = 0x3f3f3f3f;
int n, fir_d[maxn], vis[maxn], sec_d[maxn];
int head[maxn],cnt;
struct fuck {
	int u, v, ne, len;
}ed[maxn];
void add(int u, int v, int len) {
	ed[cnt].u = u; ed[cnt].v = v;
	ed[cnt].len = len; ed[cnt].ne = head[u]; head[u] = cnt++;
}
int dfs(int st,int d[]) {
	for (int s = 1; s <= n; s++)
		d[s] = inf;
	memset(vis, 0, sizeof(vis));
	d[st] = 0; vis[st] = 1;
	queue<int>q; q.push(st);
	int far = 0;
	while (!q.empty()) {
		int t = q.front(); q.pop(); vis[t] = 0;
		far = max(d[t], far);
		for (int s = head[t]; ~s; s = ed[s].ne) {
			int v = ed[s].v;
			if (d[v] > d[t] + ed[s].len) {
				d[v] = d[t] + ed[s].len;
				if (!vis[v]) {
					q.push(v);
					vis[v] = 1;
				}
			}
		}
	}
	for (int s = 1; s <= n; s++)
		if (d[s] == far)return s;
}
int main(){
	while (~scanf("%d", &n)) {
		memset(head, -1, sizeof(head)); cnt = 0;
		for (int s = 2; s <= n; s++) {
			int a, b;
			scanf("%d%d", &a, &b);
			add(a, s, b);add(s, a, b);
		}
		int st = dfs(1, fir_d);
		int en = dfs(st, fir_d);
		dfs(en, sec_d);
		for (int s = 1; s <= n; s++) 
			printf("%d\n", max(fir_d[s], sec_d[s]));
	}
}

 

   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值