X Chen笔记---Centos解决yum安装报错Protected multilib versions

今天安装gcc/g++的时候报错

yum install gcc gcc-g++ -y
  • 1

(-y 指的是如果需要选yes no的自动y)下面是报错

Protected multilib versions: libstdc++-4.8.2-8.el6.x86_64 != libstdc++-4.
  • 1
  • 2

原因是因为多个库不能共存,不过更新的话也并不行,但是可以在安装命令后面加上

--setopt=protected_multilib=false
  • 1

完整命令就是

yum install gcc gcc-g++ -y --setopt=protected_multilib=false
  • 1




阅读更多 登录后自动展开
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页