1000:A+B Problem C++题解

题目描述

Calculate a+b

输入

Two integer a,b (0<=a,b<=10)

输出

Output a+b

样例输入

1 2

样例输出

3

提示

Q: Where are the input and the output? A: Your program shall always read input from stdin (Standard Input) and write output to stdout (Standard Output). For example, you can use 'scanf' in C or 'cin' in C++ to read from stdin, and use 'printf' in C or 'cout' in C++ to write to stdout. You shall not output any extra data to standard output other than that required by the problem, otherwise you will get a "Wrong Answer". User programs are not allowed to open and read from/write to files. You will get a "Runtime Error" or a "Wrong Answer" if you try to do so. Here is a sample solution for problem 1000 using C++/G++:

#include <iostream>

using namespace std;

int  main()

{

    int a,b;

    cin >> a >> b;

    cout << a+b << endl;

    return 0;

}

It's important that the return type of main() must be int when you use G++/GCC,or you may get compile error. Here is a sample solution for problem 1000 using C/GCC:




#include <stdio.h>



int main()

{

    int a,b;

    scanf("%d %d",&a, &b);

    printf("%d\n",a+b);

    return 0;

}

Here is a sample solution for problem 1000 using PASCAL:




program p1000(Input,Output); 

var 

  a,b:Integer; 

begin 

   Readln(a,b); 

   Writeln(a+b); 

end.

Here is a sample solution for problem 1000 using JAVA: Now java compiler is jdk 1.5, next is program for 1000




import java.io.*;

import java.util.*;

public class Main

{

            public static void main(String args[]) throws Exception

            {

                    Scanner cin=new Scanner(System.in);

                    int a=cin.nextInt(),b=cin.nextInt();

                    System.out.println(a+b);

            }

}

Old program for jdk 1.4




import java.io.*;

import java.util.*;



public class Main

{

    public static void main (String args[]) throws Exception

    {

        BufferedReader stdin = 

            new BufferedReader(

                new InputStreamReader(System.in));



        String line = stdin.readLine();

        StringTokenizer st = new StringTokenizer(line);

        int a = Integer.parseInt(st.nextToken());

        int b = Integer.parseInt(st.nextToken());

        System.out.println(a+b);

    }

}

来源

POJ

#include <bits/stdc++.h>
#define cl(x) memset(x,0,sizeof(x))
#define _cl(a,b) memset(a,0,(b+1)<<2)
#define At(x,y) memset(x,y,sizeof x)
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define drep(i,a,b) for(int i=a;i>=b;i--)
#define ll long long
#define pb push_back
#define vct vector
#define pq priority_queue
#define all(x) x.begin(),x.end()
#define int long long
#define fi first
#define se second
//#pragma GCC optimize(2)
using namespace std;
inline int min(int a,int b) {return a<b?a:b;}
inline int max(int a,int b) {return a>b?a:b;}
//map<string,map<string,int> > mp;
//pq <ll,vct<ll>,less<ll> > now,last;
//vct<vct<int> > vt(n+1,vct<int>(m+1,0))
const int inf=0x3f3f3f3f;
const ll INF=0x3f3f3f3f3f3f3f3f;
const ll mod=1e9+7;
const int MOD=998244353;
const int N=1e3+10;

int n,m;


void solve()
{
    int a,b;
    cin>>a>>b;
    cout<<a+b<<"\n";
    return ;
}

signed main()
{
//    srand(time(NULL));
//    freopen("2022_XinShengSai_1.in", "r", stdin);
//    freopen("2022_XinShengSai_1.out", "w", stdout);
//    ios::sync_with_stdio(false); 
//    cin.tie(0); cout.tie(0);
    int t;
//    cin>>t;
    t=1;
    while(t--)
    solve();
    
    return 0;
}
/*

*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值