POJ-2503-Babelfish

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 47818 Accepted: 20030
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.
Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output

cat
eh
loops
解题思路: 这道题用map也可以做,但我最近学的字典树,所以用的字典树做的,map的做法比较简单 ,但空间消耗也比较大,这道题是我写的第一个用指针开些字典树的题,之前我用的都是数组模拟,但是在后来提交的时候总是RE,不明白为什么,后来看同学用的指针,,大一的时候指针没学好,就来学学,指针和数组模拟的思路是一样,但是指针空间消耗比较小,具体关于字典树的模板我就不讲了,如果不了解,可以看看网上大佬写的关于字典树的解释,很清晰。
AC代码

#include<iostream>
#include<Stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
#define maxn 27
typedef struct TrieNode
{
    char s[10];
    TrieNode *son[maxn];
}Trie;
void insertWord(Trie *root,char str1[],char str2[])
{
    Trie *p=root;
    int i=0;
    char var=str2[i];
    while(var!='\0')
    {

        if(p->son[var-'a']==NULL)
        {
            Trie *node=(Trie *)malloc(sizeof(Trie));
            for(int j=0;j<maxn;j++)
            {
                node->son[j]=NULL;
            }
            p->son[var-'a']=node;
            p=p->son[var-'a'];
        }
        else
        {
            p=p->son[var-'a'];
        }
        var=str2[++i];
    }
    strcpy(p->s,str1);
}
void findWord(Trie *root,char word[])
{
    int i=0;
    char ch=word[i];
    Trie *p=root;
    while(p!=NULL&&ch!='\0')
    {
        p=p->son[ch-'a'];
        ch=word[++i];
    }
    if(p==NULL)
        printf("eh\n");
    else
        printf("%s\n",p->s);
}
void freeTrie(Trie *root)
{
    for(int i=0;i<maxn;i++)
    {
        if(root->son[i]!=NULL)
            freeTrie(root->son[i]);
    }
    free(root);
}
int main()
{
    char ch[30],s1[11],s2[11];
    Trie *root=(Trie *)malloc(sizeof(Trie));
    for(int i=0;i<maxn;i++)
    {
        root->son[i]=NULL;
    }
    while(gets(ch))
    {
        if(strlen(ch)==0)
        {

            break;
        }
        sscanf(ch,"%s %s",s1,s2);
        insertWord(root,s1,s2);
    }
    while(gets(ch))
    {
        findWord(root,ch);
    }
    freeTrie(root);
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值