POJ_1611The Suspects

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input 

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

分析:SARS病毒在NSYSU存在,  NSYSU中有很多个的学生,编号为0的学生患有SARS,且将每个学生都分组,同一个人可以在多个组,同一组的人如果有患病的,则所有人患病,问有多少个人患病。
参考代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<vector>
#include<iostream>

using namespace std;
const int maxn = 30000+10;
const int maxm = 500+10;
int n,m;
int root[maxn];//root[i]表示i的祖先是root[i]
//int group[maxn];//group[i]表示i集合的人数

//找x的祖先
int Find( int x)
{
    //printf("$%d %d$\n",x,root[x]);
    if( x == root[x])
        return root[x];//祖先是自己
    return root[x] = Find(root[x]);
}

//合并x y
void Union( int x, int y)
{
    int px = Find(x);//找x的祖先
    int py = Find(y);//找y的祖先
    if( px == py)//x和y的祖先是同一个人
        return;
    root[px] = py;//px的祖先为py
}

int main()
{
    while( ~scanf("%d%d",&n,&m) && n)
    {
        for( int i = 0; i < n; i++)
        {
            //初始化 i的祖先还是i 每个人开始是独立的 每组一个人
            root[i] = i;
            //group[i] = 1;
        }

        for( int i = 0; i < m; i++)
        {
            int k;
            scanf("%d",&k);
            if( !k)
                continue;
            int x,y;
            scanf("%d",&x);
            for( int j = 1; j < k; j++)
            {
                scanf("%d",&y);
                Union( x,y);
            }
        }

        int tmp = Find(0);//找到0的祖先
        int ans = 1;
        for( int i = 1; i < n; i++)
        if( Find(i) == tmp)
            ans++;
        printf("%d\n",ans);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值