HDU_1856More is better

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

Sample Input 

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2
分析:一个屋子里有10000000个男孩子,王先生要他们帮他做一个项目,在一定情况下,人越多越好。可是最后只会留下一组人来,朋友的朋友也算一组人。如果所有人都不算朋友的话,毫无疑问只留下一个人;但是如果存在朋友关系的话,就留下人最多的辣一组= =

参考代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<vector>
#include<iostream>

using namespace std;
const int maxn = 10000000+10;
int n;
int pre[maxn];
int sum[maxn];

int Find( int x)
{
    if( x == pre[x])
        return x;
    return pre[x] = Find(pre[x]);

}

void Union( int x, int y)
{
    int px = Find(x);
    int py = Find(y);
    if( px == py)
        return;
    pre[px] = py;
    sum[py] += sum[px];
}

int main()
{
    while( ~scanf("%d",&n))
    {
        if( n == 0)//不存在关系时要特殊判断一下子
        {
            printf("1\n");
            continue;
        }
        for( int i = 1; i < maxn; i++)
        {
            pre[i] = i;
            sum[i] = 1;
        }
        int a,b;
        int tmp = 0;
        for( int i = 1; i <= n; i++)
        {
            scanf("%d%d",&a,&b);
            tmp = max( tmp,max(a,b));
            Union(a,b);
        }

        int ans = 0;
        for( int i = 1; i <= tmp; i++)
            ans = max( ans,sum[i]);
        printf("%d\n",ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值