Description
一颗二叉树有n(1≤n≤50)个结点,分别编号为1到n,每个结点代表一个居民点,每个居民点都有一定数量的居民(≤100)。现在需要选择一个居民点建一家医院,使得所有居民走的路程之和最小。同时约定,相邻两节点之间的距离为1。
例如对于样例,有5个居民点,每个居民点的居民数量分别为13,4,12,20,40.如果选择居民点1作为医院位置的话,则距离和为4*1+13*0+12*1+20*2+40*2=136;若选择居民点3的话,则距离和为4*2+13*1+12*0+20*1+40*1=81,…
Input
包含多组测试数据。每组测试数据第一行包含一个整数n,接下来的n行,每行3个数据,表示居民点i(1≤i≤n)的居民数和相邻两个居民点编号,如果编号为0表示不存在。
Output
输出最小距离和。
Sample Input
513 2 3
4 0 0
12 4 5
20 0 0
40 0 0
Sample Output
81分析:自我赶脚树的题目还是比较难= = 很难想象这么搞啊 可能自己太渣咯 这个题的话就是分别以每个点为建院点 然后找出和最小的辣个
参考代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<iostream>
using namespace std;
const int maxn = 55;
const int inf = 0x3f3f3f3f;
int n;
typedef struct Node{
int pre;
int num;
int l;
int r;
}Tree;
Tree t[maxn];
bool vis[maxn];
int tmp;
int ans;
void f( int now, int a)
{
if( vis[now])//已经被访问过
return;
tmp = tmp+t[now].num*a;
vis[now] = 1;
if( t[now].l)
f( t[now].l,a+1);
if( t[now].r)
f( t[now].r,a+1);
if( t[now].pre)
f( t[now].pre,a+1);
}
int main()
{
while( ~scanf("%d",&n))
{
memset(t,0,sizeof(t));
for( int i = 1; i <= n; i++)
{
scanf("%d%d%d",&t[i].num,&t[i].l,&t[i].r);
t[t[i].l].pre = i;
t[t[i].r].pre = i;
}
ans = inf;
for( int i = 1; i <= n; i++)
{
tmp = 0;
memset(vis,0,sizeof(vis));
f( i,0);
ans = min( ans,tmp);
}
printf("%d\n",ans);
}
return 0;
}