HDU_1087 Super Jumping! Jumping! Jumping!

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
Output
For each case, print the maximum according to rules, and one line one case. 
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3

题意:任选一个点,从该点开始跳跃(可跨点),求跳跃到后面点和的最大值。

分析:也就是求某个序列不一定连续递增子序列的最大和。超超超级简单的dp。用数组v[i]表示第i个值,dp[i]表示前i个点递增子序列的和(包括点i),此时分两种情况,如果v[i]>v[j](j<i),那么dp[i]=dp[j]+v[i],否则dp[i]还是当前dp[i]的值,即dp[i]=max(dp[i],dp[j]+v[i]),此时很重要的一点就是在计算dp[i]之前需要初始化dp[i]为v[i],这是前i个序列的最大递增子序列的起点和终点都为i。


参考代码:

#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cctype>
#include<cstring>
#include<string>
#include<sstream>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<iostream>

using namespace std;
typedef long long ll;
const int maxn = 1e3+10;
int n;
int v[maxn];
int dp[maxn];

int main()
{
    while( ~scanf("%d",&n) && n)
    {
        for( int i = 1; i <= n; i++)
            scanf("%d",&v[i]);
        memset(dp,0,sizeof(dp));
        dp[1] = v[1];
        int ans = dp[1];
        for( int i = 2; i <= n; i++)
        {
            dp[i] = v[i];
            for( int j = 1; j < i; j++)
            {
                if( v[i] > v[j])
                    dp[i] = max(dp[i],dp[j]+v[i]);
            }
            ans = max(ans,dp[i]);
        }

        printf("%d\n",ans);
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值