whu网络赛 E - Money

DESCRIPTION

Kile and Pogi have found ​N banknotes on the street. After making sure that the original  owner is nowhere to be found, they decided to split the banknotes amongst themselves. In the end they want to “win” the same amount of money sothey split the banknotes in such a way. Of course, the sum of the banknotes nobody ends up having is ​the least possible ​one. Since they couldn’t just leave the remaining banknotes on the street, they decided to go to a nearby casino and put everything on ​red​, hoping that they would end up getting twice the money they bet. The roulette decided on the (lucky,for this time) number 13 and our heroes decided to split the money they won. The payout is such that Kile and Pogi will always be able to split the money they won into two equal parts. Because of the immense adrenaline rush, the boys have lost their mathematical abilities. Help them figure out how much money each of them is taking home. 

INPUT

 The first line of input contains the integer ​N

​ (1 ≤ ​N ≤ 500) that denotes the number of banknotes on the street. Each of the following ​N lines contains a single positive integer ​ci​ that denotes the value of the ​ith banknote in kunas (kn). The total sum of money will not exceed 100 000 kn.  

OUTPUT

You must output the amount of money each of them took home. 

SAMPLE INPUT
4 2 3 1 6
5 2 3 5 8 13
SAMPLE OUTPUT
6
18
分析:描述的这么一大堆的东西和题意无关!?原谅我六级还没过……看了题解之后,才知道这是0-1背包的问题,求组成的最大n且n为偶数,且也可以组成n/2,最终结果为 (sum-n)+n/2

参考代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;
const int maxn = 500+10;
const int maxm = 100000+10;
int n;
int c[maxn];
int dp[maxm];

int main()
{
    while( ~scanf("%d",&n))
    {
        int sum = 0;
        for( int i = 1; i <= n; i++)
        {
            scanf("%d",&c[i]);
            sum += c[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        for( int i = 1; i <= n; i++)
        {
            for( int j = sum; j >= c[i]; j--)
                if( dp[j-c[i]])
                    dp[j] = 1;
        }

        //for( int i = 1; i <= sum; i++)
          //  printf("%d_%d\n",i,dp[i]);

        int tmp = 0;
        for( int i = sum; i >= 0; i--)
        {
            if( !(i&1) && dp[i] && dp[i>>1])
            {
                tmp = (i>>1);
                break;
            }
        }
        //printf("%d %d ",sum,tmp);
        printf("%d\n",sum-tmp);

    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值