HDU - 2795 Billboard(线段树,单点更新,最值问题)

Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3

-1

题意:在一个长宽为h*w的板子上粘贴长宽为1*wi的广告,每一个广告都尽量贴在左上角,如果可以贴上去就输出广告被粘贴的行数(从上到下为1-n),如果不可以贴上去,输出-1

分析:根据题意,可以转化为利用线段树求最值问题。将板子的高分成h个点,建成一个线段树,然后比较要查询的点的值和树上每个节点的值的大小,看能不能找出width满足的节点(此节点一定为叶子节点,因为所有叶子节点的最大值为根节点的值…),当然首先要特别判断根节点的值是否大于等于要查询的wi,如果不大于的话,直接输出-1

参考代码:

#include<cstdio>
#include<cmath>
#include<cctype>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<list>
#include<vector>
#include<iostream>

using namespace std;
const int maxn = 2e5+100;//最多只有2e5个广告,就算每个广告的长度都为最大w,也只需要2e5层就放的下了
int h,w,n;
struct Node{
    int l,r;
    int maxx;
};
Node segtree[maxn<<2];

void Build( int l, int r, int rt, int w)
{
    segtree[rt].l = l;
    segtree[rt].r = r;
    segtree[rt].maxx = w;
    if( l == r)
        return;
    int m = (l+r)>>1;
    Build(l,m,rt<<1,w);//建立左子树
    Build(m+1,r,rt<<1|1,w);//建立右子树
}

void PushUp( int rt)
{
    segtree[rt].maxx = max(segtree[rt<<1].maxx,segtree[rt<<1|1].maxx);
}

void Update( int wi, int rt)
{
    if( segtree[rt].l == segtree[rt].r)
    {
        printf("%d\n",segtree[rt].l);
        segtree[rt].maxx -= wi;
        return;
    }

    if( wi <= segtree[rt<<1].maxx)
        Update(wi,rt<<1);
    else
        Update(wi,rt<<1|1);
    PushUp(rt);
}

int main()
{
    while( ~scanf("%d%d%d",&h,&w,&n))
    {
        if( h > n)
            h = n;
        Build(1,h,1,w);//建树,以h为叶子节点个数
        int wi;
        for( int i = 1; i <= n; i++)
        {
            scanf("%d",&wi);
            if( segtree[1].maxx >= wi)
                Update(wi,1);
            else
                printf("-1\n");
        }
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值