POJ1154--LETTERS(DFS)

LETTERS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7805 Accepted: 3544

Description

A single-player game is played on a rectangular board divided in R rows and C columns. There is a single uppercase letter (A-Z) written in every position in the board. 
Before the begging of the game there is a figure in the upper-left corner of the board (first row, first column). In every move, a player can move the figure to the one of the adjacent positions (up, down,left or right). Only constraint is that a figure cannot visit a position marked with the same letter twice. 
The goal of the game is to play as many moves as possible. 
Write a program that will calculate the maximal number of positions in the board the figure can visit in a single game.

Input

The first line of the input contains two integers R and C, separated by a single blank character, 1 <= R, S <= 20. 
The following R lines contain S characters each. Each line represents one row in the board.

Output

The first and only line of the output should contain the maximal number of position in the board the figure can visit.

Sample Input

3 6
HFDFFB
AJHGDH
DGAGEH

Sample Output

6

大致题意为:从(0,0)点开始搜,最多可以经过多少个不同的字母

H-A-D-G-J-F  为其中一种,经过了6个字母

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;
int map[20][20];
int S,R;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int vis[30];
int maxnum;
int countnum;

void dfs(int x,int y)
{
    for(int i=0;i<4;i++)
    {
        int x1 = x+dir[i][0];
        int y1 = y+dir[i][1];
        if(x1<0||y1<0||x1>=S||y1>=R)
            continue;
        if(!vis[map[x1][y1]])
        {
            countnum++;
            vis[map[x1][y1]]=1;
            dfs(x1,y1);
            maxnum=max(countnum,maxnum);
            //状态还原
            vis[map[x1][y1]]=0;
            countnum--;
        }
        
    }

}

int main()
{
    while(cin>>S>>R)
    {
        //初始值都要赋值为1
        maxnum=1;
        string str;
        memset(vis,0,sizeof(vis));
        for(int i =0;i<S;i++)
        {
            cin>>str;
            for(int j=0;j<R;j++)
            {
                map[i][j] = str[j]-'A'+1;
                //cout<<map[i][j]<<endl;
            }
        }
        countnum=1;
        vis[map[0][0]]=1;
        dfs(0,0);
        cout << maxnum << endl;

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值