PAT B1004 成绩排名 (20分) ---结构体

 

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112
#include<cstdio>
#include<iostream>
using namespace std;
struct student{
	char name[20];
	char num[20];
	int  score;
};
int main(){
	int n;
	scanf("%d",&n);
	int max=0,min=100;
	int maxi,mini;
	struct student student[n];    //第一个student为struct类型,第二个为定义的变量。 
	for(int i=0;i<n;i++){
		scanf("%s %s %d",student[i].name,student[i].num,&student[i].score); 
	}
	for(int i=0;i<n;i++){
		if(student[i].score>=max) maxi=i,max=student[i].score;
		if(student[i].score<=min) mini=i,min=student[i].score;
	}
	printf("%s %s\n",student[maxi].name,student[maxi].num);
	printf("%s %s",student[mini].name,student[mini].num);
	return 0;
}

 再次写的时候发现还是有点不熟悉结构体的用法~

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
typedef struct stu{
	string name,xh;
	int score;
};
bool cmp(stu a,stu b){
	return a.score<b.score;
}
int main(){
	int n;
	cin>>n;
	stu student[100000];
	for(int i=0;i<n;i++){
		cin>>student[i].name>>student[i].xh>>student[i].score;
	}
	sort(student,student+n,cmp);
	cout<<student[n-1].name<<" "<<student[n-1].xh<<endl;
	cout<<student[0].name<<" "<<student[0].xh;
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值