ZOJ Problem Set - 2100

ZOJ Problem Set - 2100
Seeding
Time Limit: 1 Second       Memory Limit: 32768 KB
It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

=============

典型的DFS题,很不错。

题目很简单,从左上角出发,判断是否能完全把地耕玩(拖拉机不能在石块和已经耕好的地上行驶。)

#include <stdio.h>
#include <string.h>
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};//四个方向 
char map[10][10];//定义一张地图 
int done;
int Flag;
int n,m;
void dfs(int x,int y) 
{
  int i;
  if(x<1 || y<1 || x>n || y>m)   return;//判断是否越界  
  done++; 
  if(done==n*m)//如果成功则返回 
  {
     Flag=1;
     return;
  }
  for(i=0;i<4;i++)
  {
     if(map[x+dir[i][0]][y+dir[i][1]]=='.')
     {
	 
	     map[x+dir[i][0]][y+dir[i][1]]='S';//标记已经耕过的土地 
	     dfs(x+dir[i][0],y+dir[i][1]);
	 }
  }
  done--;
  map[x][y]='.';
}
int main()
{
   int i,j;  
   memset(map,'S',sizeof(map));
   while(scanf("%d%d%*c",&n,&m)!=EOF)
   {
      if(n==0 && m==0)
      break;
      done=0;
      Flag=0;
      for(i=1;i<=n;i++)
      {
	     
		 for(j=1;j<=m;j++)
	     {
		    scanf("%c",&map[i][j]);
		    if(map[i][j]=='S')
		    done++;
		 }
		 getchar();
	  
	  }
	 	 
	  map[1][1]='S';
	  dfs(1,1);
	  if(Flag==1)
	  printf("YES\n");
	  else
	  printf("NO\n");
   }
return 0;

}

转载于:https://my.oschina.net/OceanEyes/blog/381438

Antique Comedians of Malidinesia would like to play a new discovered comedy of Aristofanes. Putting it on a stage should be a big surprise for the audience so all the preparations must be kept absolutely secret. The ACM director suspects one of his competitors of reading his correspondece. To prevent other companies from revealing his secret, he decided to use a substitution cipher in all the letters mentioning the new play. Substitution cipher is defined by a substitution table assigning each character of the substitution alphabet another character of the same alphabet. The assignment is a bijection (to each character exactly one character is assigned -- not neccessary different). The director is afraid of disclosing the substitution table and therefore he changes it frequently. After each change he chooses a few words from a dictionary by random, encrypts them and sends them together with an encrypted message. The plain (i.e. non-encrypted) words are sent by a secure channel, not by mail. The recipient of the message can then compare plain and encrypted words and create a new substitution table. Unfortunately, one of the ACM cipher specialists have found that this system is sometimes insecure. Some messages can be decrypted by the rival company even without knowing the plain words. The reason is that when the director chooses the words from the dictionary and encrypts them, he never changes their order (the words in the dictionary are lexicographically sorted). String a1a2 ... ap is lexicografically smaller than b1b2 ... bq if there exists an integer i, i <= p, i <= q, such that aj=bj for each j, 1 <= j < i and ai < bi. The director is interested in which of his messages could be read by the rival company. You are to write a program to determine that. Input Output Sample Input 2 5 6 cebdbac cac ecd dca aba bac cedab 4 4 cca cad aac bca bdac Sample Output abcde Message cannot be decrypted.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值