POJ2386

原题连接:http://poj.org/problem?id=2386

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18126 Accepted: 9149

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

题目简述,有一块地下雨之后又积水,W的地方就是表示有积水。要求有多少水洼。上下左右8个方向联通的就算一个水洼。

如图就是有三个水洼。

有一个小技巧,我觉得代码是死的,但是很值得收藏~

//值得收藏的代码,表示一个点上下左右的8个方向,下面的代码表示的是x,y原点
int nx,ny,x,y;
for(int dx = -1; dx <= 1; dx++)
{
	for(int dy = -1; dy <= 1; dy++)
	{
		nx = x + dx;
		ny = y + dy;
	}
}


//表示一个点上下左右的4个方向,要求的是x,y上下左右四个方向的点
int nx,ny,x,y;
int dx[4] = {1,0,-1,0}, dy={0,1,0,-1}
for(int i = 0; i < 4 ; i++)
{
	nx = x + dx[i], ny = y + dy[i];
}

#include<stdio.h>
#define MAX 100

int N,M;
char field[MAX][MAX];
void dfs(int x, int y)
{
    field[x][y] = '.';
	for(int dx = -1; dx <= 1; dx++)
	{
		for(int dy = -1; dy <= 1; dy++)
		{
			int nx = x + dx;
			int ny = y + dy;
			if(nx>=0 && nx<N && ny>=0 && ny<M && field[nx][ny]=='W')
				dfs(nx,ny);
		}
	}
}
int main()
{
	while(scanf("%d%d",&N.&M)!=EOF)
	{
		for(int i = 0; i < N; i++)
		{
			for(int j =0; j < M; j++)
			{
				scanf("%d", &field[i][j]);				
			}
			getchar();
		}
		for(int i = 0; i < N; i++)
		{
			for(int j = 0; j < M; j++)
			{
			    if(field[i][j]=='W')
				{
					dfs(i,j);
					res++;
				}
				
			}
		}
	}
	return 0;
}

找水洼就是找dfs做了几次。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值