hdu 1159 Common Subsequence

算是dp入门题吧,之前不知道dp的时候,就只知道暴力,知道了一点后,就这道题,想了好久还是写不出来,最后还是看题解明白的,典型的时间换空间,算是一道经典题吧,记录下来,算是自己的一点小收获吧。
对了,之前Max函数,写成 if(a>b)return a ;else return b; 这样写居然会超时!!!要写成 return a>b?a:b;

画了一个表,方便理解:
第一个列子

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest
abcd mnp

Sample Output
4
2
0
代码如下:

#include<cstdio>
#include<cstring>
char x[100],y[100];
int dp[100][100];

int Max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	while(scanf("%s %s",x,y))
	{
		memset(dp,0,sizeof(dp));
		int n=strlen(x);
		int m=strlen(y);
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if(x[i-1]==y[j-1])
					dp[i][j]=dp[i-1][j-1]+1;
				else
					dp[i][j]=Max(dp[i-1][j],dp[i][j-1]);
			}
		}
		printf("%d\n",dp[n][m]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值