poj2407 Relatives ——欧拉函数

题目描述

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
输入
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
输出
For each test case there should be single line of output answering the question posed above.
样例输入
7
12
0
样例输出
6
4

题意
给你数 x,求φ(x),多组输入

题解
根据公式 当 x=a1^k1+a2^k2+…+an^kn,φ(x)=x*(1-1/a1) (1-1/a2)…*(1-1/an)
利用公式就可以在 O(sqrt(x)) 的时间内求出φ(x)

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int n;
int phi(int x){
    int num=x;
    for(int i=2;i*i<=x;i++)
        if(x%i==0){
            num=num/i*(i-1);
            while(x%i==0) x/=i;}
    if(x>1) num=num/x*(x-1);
    return num;}
int main(){
    while(~scanf("%d",&n)){
        if(!n) return 0;
        printf("%d\n",phi(n));}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值