滑雪

Description
顺治喜欢滑雪,这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待太监们来载你。顺治想知道载一个区域中最长的滑坡。 区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子:

1 2 3 4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

顺治可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 < = R,C < = 500)。下面是R行,每行有C个整数,代表高度h,0< =h< =10000。
Output
输出最长区域的长度。
Sample Input Copy
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output Copy
25

PS
没什么好说的,因为输入的n和m弄反了,一直错36%。对自己贼无语。

方法1

#include<bits/stdc++.h>
using namespace std;
#define ios ios::sync_with_stdio(false); cin.tie(NULL);
const int N = 510;
int n;
int m;
int ans;
int nice;
int mp[N][N];
struct node
{
    int a,b;
} str;
int fx[] = {0,1,0,-1};
int fy[] = {-1,0,1,0};
bool vis[N][N];
int dp[N][N];//存储每个点的最优解;
bool check(int x,int y)
{
    if(x>=1&&x<=m&&y>=1&&y<=n&&!vis[x][y])
        return true;
    return false;
}

void dfs(int x,int y)
{
    if(ans>nice)
    {
        nice = ans;
    }
    for(int i=0; i<4; i++)
    {
        str.a = x+fx[i];
        str.b = y+fy[i];
        if(check(str.a,str.b)&&mp[x][y]>mp[str.a][str.b])
        {
            if(dp[str.a][str.b]>0)
            {
                if(ans+dp[str.a][str.b]>nice)
                    nice = ans+dp[str.a][str.b];
                continue;
            }
            vis[x][y] = true;
            ans++;
            dfs(str.a,str.b);
            ans--;
            vis[x][y] = false;
        }
    }
}


int main()
{
    cin>>m>>n;
    for(int i=1; i<=m; i++)
    {
        for(int j=1; j<=n; j++)
        {
            cin>>mp[i][j];
        }
    }
    ans=1;
    for(int i=1; i<=m; i++)
    {
        for(int j=1; j<=n; j++)
        {
            dfs(i,j);
            dp[i][j] = nice;
            nice =0;
            ans=1;
        }
    }
    for(int i=1; i<=m; i++)
    {
        for(int j=1; j<=n; j++)
        {
              if(dp[i][j]>nice)
                nice = dp[i][j];
        }
    }
    cout<<nice;
    return 0;
}

方法2

#include<bits/stdc++.h>
using namespace std;
#define ios ios::sync_with_stdio(false); cin.tie(NULL);
const int N = 510;
int n;
int m;
int ans;
int nice;
int mp[N][N];
struct node
{
    int a,b;
} str;
int fx[] = {0,1,0,-1};
int fy[] = {-1,0,1,0};
bool vis[N][N];
int dp[N][N];//存储每个点的最优解;
bool check(int x,int y)
{
    if(x>=1&&x<=m&&y>=1&&y<=n&&!vis[x][y])
        return true;
    return false;
}
 
void dfs(int x,int y)
{
    if(ans>nice)
    {
        nice = ans;
    }
    for(int i=0; i<4; i++)
    {
        str.a = x+fx[i];
        str.b = y+fy[i];
        if(check(str.a,str.b)&&mp[x][y]>mp[str.a][str.b])
        {
            if(dp[str.a][str.b]>0)
            {
                if(ans+dp[str.a][str.b]>nice)
                    nice = ans+dp[str.a][str.b];
                continue;
            }
            vis[x][y] = true;
            ans++;
            dfs(str.a,str.b);
            ans--;
            vis[x][y] = false;
        }
    }
}
 
 
int main()
{
    cin>>m>>n;
    for(int i=1; i<=m; i++)
    {
        for(int j=1; j<=n; j++)
        {
            cin>>mp[i][j];
        }
    }
    ans=1;
    for(int i=1; i<=m; i++)
    {
        for(int j=1; j<=n; j++)
        {
            dfs(i,j);
            dp[i][j] = nice;
            nice =0;
            ans=1;
        }
    }
    for(int i=1; i<=m; i++)
    {
        for(int j=1; j<=n; j++)
        {
              if(dp[i][j]>nice)
                nice = dp[i][j];
        }
    }
    cout<<nice;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值