2.7节 C语言10.15

C语言10.15

时间限制: 1 Sec  内存限制: 32 MB

题目描述

输入3个字符串,按从小到大的顺序输出。要求使用指针的方法进行处理。

输入

3行,每行一个用字符串。保证每个字符串的长度不超过20。

输出

按从小到大的顺序输出这3个字符串,每个字符串一行。
请注意行尾输出换行。

样例输入

China
CLOCK
deal

样例输出

CLOCK
China
deal

Code:

#include <stdio.h>
int main(){
	char s1[20],s2[20],s3[20];
	char* a=s1,* b=s2,* c=s3;
	gets(a);
	gets(b);
	gets(c);
	if(*a==*b){
		a++;b++;
		
	}
	else if(*a>*b){
		int temp=*a;
		*a=*b;
		*b=temp;
	}
	a=&s1[0];
	b=&s2[0];
	if(*a==*c){
		a++;c++;
	}
	else if(*a>*c){
		int temp=*a;
		*a=*c;
		*c=temp;
	}
	a=&s1[0];
	c=&s3[0];
	if(*b==*c){
		b++;c++;
	}
	else if(*b>*c){
		int temp=*b;
		*b=*c;
		*c=temp;
	}
	puts(s1);
	puts(s2);
	puts(s3);
	return 0;
}

 

转载于:https://my.oschina.net/u/3170021/blog/896625

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值