Sicily 14513. Aaah!

14513. Aaah!
 
     
     
 
Time Limit: 1sec    Memory Limit:256MB
Description

Jon Marius shouted too much at the recent Justin Bieber concert, and now needs to go to the doctor because of his sore throat. The doctor’s instructions are to say “aaah”. Unfortunately, the doctors sometimes need Jon Marius to say “aaah” for a while, which Jon Marius has never been good at. Each doctor requires a certain level of “aah” – some require “aaaaaah”, while others can actually diagnose his throat with just a “h”. (They often diagnose wrongly, but that is beyond the scope of this problem.) Since Jon Marius does not want to go to a doctor and have his time wasted, he wants to compare how long he manages to hold the “aaah” with the doctor’s requirements. (After all, who wants to be all like “aaah” when the doctor wants you to go “aaaaaah”?)

Each day Jon Marius calls up a different doctor and asks them how long his “aaah” has to be. Find out if Jon Marius would waste his time going to the given doctor.

Input

The input consists of two lines. The first line is the “aaah” Jon Marius is able to say that day. The second line is the “aah” the doctor wants to hear. Only lowercase ’a’ and ’h’ will be used in the input, and each line will contain between 0 and 999 ’a’s, inclusive, followed by a single ’h’.

The input contains multiple test cases. End of file (EOF) indicates the end of input.

Output

Output “go” if Jon Marius can go to that doctor, and output “no” otherwise.

Sample Input
 Copy sample input to clipboard
aaah
aaaaah
aaah
ah
Sample Output
no
go

Problem Source: 2015年每周一赛第十场--省赛模拟赛I

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
string s1,s2;
const int INF = 4294967295; //表示找不到 
int main(){
    while(cin>>s1>>s2){
        int ans = s1.find(s2);
        if(ans >= 0)printf("go\n");
        else printf("no\n");
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值