A+B for Input-Output Practice (VIII)(没啥用,来凑数)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 127789    Accepted Submission(s): 38920


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
  
  
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

Sample Output
  
  
10 15 6
 

代码实现:
#include<stdio.h>
int main()
{
    int T,n,a,sum=0,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a);
            sum+=a;
        }
        printf("%d\n",sum);
        sum=0;
        if(T!=0)
            printf("\n");
    }
}
我写的():
#include<iostream>
using namespace std;
int main()
{
	int T,A[1000];
	cin>>T;
	while(T--)
	{
		int sum=0;
		cin>>A[0]>>A[1];
		int i=1;
		while(A[i]!=A[0])
		{
			i++;
			cin>>A[i];
		}
		for(int j=0;j<i;j++)
		    sum+=A[j]; 
		if(T)
		    cout<<sum<<endl<<endl;
		else
		    cout<<sum<<endl;
	}
	return 0;
}
 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值