zoj 1001 a + b问题

----------------------------------------------------------------------------------------------------------------------------------

Calculate a + b

Input

    The input will consist of a series of pairs integers a and b, separater,one opair of intergers

per line

 

Output

     For each pair of input intergers a and b you should output the sum of a and b in one line,and 

with one line of output for each line in input.

 

Sample Input

1 5

Sample Output

6

-------------------------------------------------------------------------------------------------------------------------------------

C:

   scanf  速度快

   printf 格式容易控制

C++:

  cin 使用简单,自动识别类型

  cout 格式控制较麻烦

数据规模较大时,使用scanf以避免超时(TLE)

 

C language:

#include<stdio.h>

int main()

{

     int a, b;

    while(scanf("%d, %d",&a, &b) != EOF)   //不断输入,直到文件为空

        printf("%d\n", a + b);   //输出a和b之和,并换行

    return 0;

}

---------------------------------------------------------------------------------------------------------------------------------------

C++ language:

#include<iostream>
using namespace std;


int main()

{
    int a, b;
    while (cin >> a >> b)
        cout << (a + b) << endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值