CCPC[长春] 6.Harmonic Value Description 规律+贪心

Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0
Special Judge


Problem Description
The harmonic value of the permutation  p1,p2,pn  is
i=1n1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
 

Input
The first line contains only one integer T ( 1T100 ), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k ( 12kn10000 ).
 

Output
For each test case, output one line “Case #x:  p1 p2  pn ”, where x is the case number (starting from 1) and  p1 p2  pn  is the answer.
 

Sample Input
  
  
2 4 1 4 2
 

Sample Output
  
  
Case #1: 4 1 3 2 Case #2: 2 4 1 3
 

Statistic |  Submit |  Clarifications |  Back


经过总结规律,4个数的harmonic value为3 4....

5个的为 4 5 ....

6个的为5 6....

7个的为6 7 .....

8个的为7 8 ....

........

n个的为n-1  n ....

所以第k小的数的harmonic value为n-2+k


然后再利用贪心算法,把后面的数的位置放到适当位置,

使其harmonic value的值为n-2+k

具体分析看代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define rep(i,m,n) for(i=m;i<=n;i++)
#define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
const int inf_int = 2e9;
const long long inf_ll = 2e18;
#define inf_add 0x3f3f3f3f
#define mod 1000000007
#define vi vector<int>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define PI acos(-1.0)
#define pii pair<int,int>
#define Lson L, mid, rt<<1
#define Rson mid+1, R, rt<<1|1
const int maxn=5e2+10;
using namespace std;
typedef  long long ll;
typedef  unsigned long long  ull; 
inline int read(){int ra,fh;char rx;rx=getchar(),ra=0,fh=1;
while((rx<'0'||rx>'9')&&rx!='-')rx=getchar();if(rx=='-')
fh=-1,rx=getchar();while(rx>='0'&&rx<='9')ra*=10,ra+=rx-48,
rx=getchar();return ra*fh;}
//#pragma comment(linker, "/STACK:102400000,102400000")
ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};


int T,n;
int a[10005];

int m,m1;
int main()
{
    
    scanf("%d",&T);
    for(int k=1;k<=T;k++)
    {
        memset(a,0,sizeof(a));
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++)
            a[i]=i;
        m--;
        if(m%2==1)
        {
            for(int j=(m+1)*2;j>m+2;j--)//前移一个数
                a[j]=a[j-1];
            a[m+2]=(m+1)*2;
        }
        else
        {
            for(int j=m*2;j>m+1;j--)//前移一个数
                a[j]=a[j-1];
            a[m+1]=m*2;
            
            if(n%2==0)//交换
            {
                int t;
                t = a[n];
                a[n]=a[n-1];
                a[n-1]=t; 
            }
            else
            {
                int t;
                t = a[n-3];
                a[n-3]=a[n-2];
                a[n-2]=t;
            }
        }
        printf("Case #%d:",k);
        for(int i=1;i<=n;i++)    
            printf(" %d",a[i]);
        printf("\n");
    } 
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值