C语言实验——找中间数

Problem Description

输入三个整数,找出其中的中间数。(这里的中间数指的是大小,不是位置。)

Input

输入3个整数。

Output

输出中间数。

Example Input
1 2 3
Example Output
2

 

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int a,b,c,d,e;
    scanf("%d",&a);
    b = a% 10;
    c = a/10%10;
    d = a/100;
    e = b*100 + c*10 +d*1;
    printf("%d\n",e);

    return 0;
}
 

转载于:https://my.oschina.net/u/2601269/blog/754226

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值