1009 Product of Polynomials (25)

Product of Polynomials(多项式的积).

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, 
and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, 
where K is the number of nonzero terms in the polynomial, 
Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients(指数和系数), respectively. 
	例如:指数为3,系数为3,则即为27.
It is given that 1 <= K <= 2000, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:
For each test case you should output the product of A and B in one line, 
with the same format as the input. 
Notice that there must be NO extra space at the end of each line. 
Please be accurate up to 1 decimal place.

Sample Input
2         1(指) 2.4(系)     0  3.2
2         2     1.5         1  0.5
Sample Output
3         3     3.6         2  6.0         1 1.6

#include <cstdio>
#include <cstring>
const int MAXN = 10100;
int main() {
	double number1[MAXN], number2[MAXN], number3[MAXN];
	int K1, K2, maxIndex1 = 0, maxIndex2 = 0;
	memset(number1,0.0,MAXN);
	memset(number2,0.0,MAXN);
	memset(number3,0.0,MAXN);
	scanf("%d",&K1);
	for(int i=0; i<K1; i++) {
		int e;
		double c;
		scanf("%d%lf",&e,&c);
		number1[e] += c;
		if(maxIndex1 < e) maxIndex1 = e;
	}
	scanf("%d",&K2);
	for(int i=0; i<K2; i++) {
		int e;
		double c;
		scanf("%d%lf",&e,&c);
		number2[e] += c;
		if(maxIndex2 < e) maxIndex2 = e;
	}
	for(int i=0; i<=maxIndex1; i++)
		for(int j=0; j<=maxIndex2; j++)
			if(number1[i] != 0.0 && number2[j] != 0.0)
				number3[i + j] += number1[i] * number2[j];
	int cnt = 0;
	for(int i=maxIndex1 + maxIndex2; i>=0; i--)
		if(number3[i] != 0.0)
			cnt++;
	printf("%d",cnt);
	for(int i=maxIndex1 + maxIndex2; i>=0; i--)
		if(number3[i] != 0.0)
			printf(" %d %0.1f",i, number3[i]);
			//printf(" %d %g",i, number3[i]);  // %g
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值