九度1439:Least Common Multiple

题目1439:Least Common Multiple

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:6175

解决:1855

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105

10296

本题求多个数的最小公倍数。GCD/LCM的问题都比较简单,记住欧几里得算法就行了,LCM在算出GCD之后简单处理一下即可。对于多个数,我是先把他们升序排序,然后两两求LCM,最后求得的一定是他们全部的LCM。需要注意的是数的范围,本题要用long才不会出错。

  

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
long gcd(long a,long b)
{
    if(b==0)    return a;
    return gcd(b,a%b);
}
int main()
{
    int t;
    cin>>t;
    while(t--){
        int m;
        cin>>m;
        long *a=new long[m+1];
        memset(a,0,sizeof(a[0])*m);
        for(int i=0;i<m;i++)
            cin>>a[i];
        sort(a,a+m);
        long tmp=1;
        for(int i=0;i<m;i++)
            tmp=tmp*a[i]/gcd(tmp,a[i]);
        cout<<tmp<< endl;
    }
    return 0;
}
**********************************************

坚持,而不是打鸡血~
                                                                                                                

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值