HDOJ 5155 Harry And Magic Box DP


dp[i][j] 表示 长宽为i,j的矩形的可能的总数

dp[i][j+1] 可由 dp[i][j] 推过来,枚举dp[i][j]所保留的行数(1...i)即可

Harry And Magic Box

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 441    Accepted Submission(s): 209


Problem Description
One day, Harry got a magical box. The box is made of n*m grids. There are sparking jewel in some grids. But the top and bottom of the box is locked by amazing magic, so Harry can’t see the inside from the top or bottom. However, four sides of the box are transparent, so Harry can see the inside from the four sides. Seeing from the left of the box, Harry finds each row is shining(it means each row has at least one jewel). And seeing from the front of the box, each column is shining(it means each column has at least one jewel). Harry wants to know how many kinds of jewel’s distribution are there in the box.And the answer may be too large, you should output the answer mod 1000000007.
 

Input
There are several test cases.
For each test case,there are two integers n and m indicating the size of the box.  0n,m50 .
 

Output
For each test case, just output one line that contains an integer indicating the answer.
 

Sample Input
  
  
1 1 2 2 2 3
 

Sample Output
  
  
1 7 25
Hint
There are 7 possible arrangements for the second test case. They are: 11 11 11 10 11 01 10 11 01 11 01 10 10 01 Assume that a grids is '1' when it contains a jewel otherwise not.
 

Source
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年02月15日 星期日 22时41分33秒
File Name     :HDOJ5155.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;

const LL mod=1000000007LL; 

LL dp[100][100];
LL C[100][100];
LL two[100];

void init()
{
	for(int i=1;i<=50;i++)
	{
		dp[1][i]=dp[i][1]=1LL;
		two[i]=(1LL<<i)%mod;
	}

	for(int i=1;i<=50;i++)
		C[i][0]=C[i][i]=1LL;
	for(int i=2;i<=50;i++)
	{
		for(int j=1;j<i;j++)
		{
			C[i][j]=(C[i-1][j]+C[i-1][j-1])%mod;
		}
	}

	for(int i=1;i<=50;i++)
	{
		for(int j=1;j<=50;j++)
		{
			if(dp[i][j]==0)
			{
				LL temp=dp[i][j-1]*(two[i]+mod-1)%mod;
				for(int k=1;k<i;k++) 
				{
					temp=(temp+((C[i][k]*dp[i-k][j-1])%mod*two[i-k])%mod)%mod;
				}
				dp[i][j]=dp[j][i]=temp;
			}
		}
	}
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int a,b;
	init();
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		cout<<dp[a][b]<<endl;
	}
    
    return 0;
}



评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值