题目1095:The 3n + 1 problem

时间限制: 1s 内存限制: 64MB 提交: 21767 解决: 6122

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22: 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000, 000. For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.

输入格式

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出格式

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

样例输入

1 10
100 200
201 210
900 1000

样例输出

1 10 20
100 200 125
201 210 89
900 1000 174

总结:用递归来实现就很简单了

#include<iostream>
#define maxsize 10000
using namespace std;
int func(int b,int c) {
	if (b == 1) return c;
	if (b % 2 == 0) {
		c++;
		return func(b / 2,c);
	}
	else {
		c++;
		return func(3 * b + 1,c);
	}
}
int main() {
	long long i,j;
	while (cin >> i >> j) {
		cout << i << " " << j <<" ";
		int tmp;
		if (i > j) {
			tmp = j;
			j = i;
			i = tmp;
		}
		int maxrs = 0;
		int tmp = 0;
		for (int m = i; m <= j; m++) {
			maxrs = max(tmp, func(m, 1));
			tmp = maxrs;
		}
		cout << maxrs << endl;
	}		
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值