Sciliy 1007. To and Fro


Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number ofcolumns and write the message (letters only) down the columns, padding with extra random letters soas to make a rectangular array of letters. For example, if the message is "There's no place like home ona snowy night" and there are five columns, Mo would write downt o i o yh p k n ne l e a ir a h s ge c o n hs e m o tn l e w xNote that Mo includes only letters and writes them all in lower case. In this example, Mo used thecharacter `x' to pad the message out to make a rectangle, although he could have used any letter.Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right andright-to-left. So, the above would be encrypted astoioynnkpheleaigshareconhtomesnlewxYour job is to recover for Larry the original message (along with any extra padding letters) from theencrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will containan integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of upto 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end ofinput.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

题目大意:

讲不清楚。。。

给出一段字母,把它从左到右,从右到左排列成矩阵,每行n个字母。然后每列地输出


下面给个思路比较清晰的代码,最开先自己写,虽然ac了,但是思路超级混乱。

这个代码的思路是用一个二维矩阵根据输入顺序存储,但是二维数组的顺序是有序的。


#include<iostream>
#include<cstring>
using namespace std;
char cra[21][101];
char charactor[201];
int main()
{
	int n;
	while(cin>>n&&n>=2&&n<=20&&n!=0)
	{
		cin>>charactor;
		int len=strlen(charactor);
		int row=len/n;
		int x=0,y=0;
		for(int i=0;i<len;i++)
		{
			cra[x][y]=charactor[i];
			if(x%2==0)
			{
				y++;
				if(y==n)
				{
					x++;
					y--;
				}
			}
			else 
			{
				y--;
				if(y==-1)
				{
					x++;
					y++;
				}
			}
		}
		for(int j=0;j<n;j++)
		{
			for(int i=0;i<len/n;i++)
			{
				cout<<cra[i][j];
			}
		}
		cout<<endl;
	}
	return 0;
	
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值